Weekly Edition for Thursday, Jan 17

Newsletters

Releases

project release date
c-lightning v0.6.3

We're pleased to announce c-lightning 0.6.3, named by @molxyz and @ctrlbreak.

We highly recommend you upgrade to this release soon; it fixes a crashing bug which has been plaguing multiple users (reproduced and verified fixed by our intrepid release-namers above).

Highlights for Users

  • Private channel creation support.
  • option_dataloss_protect temporarily disabled, as it seems incompatible with lnd in some cases.
  • Better handling of less common BOLT11 invoices.
  • Less crashy!
  • Alpha release of plugin support (use ./configure --enable-plugins), so you can extend your node's capabilities (see https://github.com/ElementsProject/lightning/blob/master/doc/plugins.md)

Highlights for the network

  • We no longer send invalid error messages if you get a peer id wrong.
  • We allow update_fee before funding_locked which lnd sometimes does (we used to close channel!).

More details can be found in the https://github.com/ElementsProject/lightning/blob/v0.6.3/CHANGELOG.md:

Contributions

We're grateful for all the bug reports and suggestions and your patience as we sometimes struggled to address them: please keep them coming!

Since 0.6.2 we've had 314 commits from 18 different authors, 5 of whom were first-time c-lightning contributors:

  • Conor Scott @conscott
  • Franck Royer @D4nte
  • Michael Hawkins @runcrypto-michael
  • Richard Bondi @rsbondi

This is up from last release, despite the holiday break!

Cheers, Rusty, Christian and ZmnSCPxj.

2019-01-11
zap-desktop v0.3.3-beta

Bug Fixes

  • btc: remove unnecessary price parameters (498f76d), closes #1333
  • btc: use correct parameter when converting from millisats to fiat (5292312), closes #1322
  • deps: deps: update dependency bolt11 to fix uppercase parsing (7cc3938)
  • deps: update dependency downshift to v3.1.12 (#1265) (002f476)
  • deps: update dependency electron to v4 (#1137) (c73fbc7)
  • deps: update dependency electron to v4.0.1 (#1249) (8b80b37)
  • deps: update dependency qrcode.react to v0.9.1 (#1183) (9a5a798)
  • deps: update dependency qrcode.react to v0.9.2 (#1237) (2bdfecb)
  • deps: update dependency react-spring to v7.2.7 (#1197) (4db1bb0)
  • deps: update dependency react-spring to v7.2.8 (#1252) (eab3ed6)
  • deps: update react monorepo to v16.7.0 (#1132) (cc00902)
  • i18n: add intl support for activity header (5044783)
  • i18n: ensure modal help link is translatable (05d9e07), closes #1271
  • lnd: fix describe network fetching (44dfc67)
  • network: add fiat amount to channel form (1b7a346)
  • onboarding: better categorize macaroon error (092a1da)
  • onboarding: handle btcpayserver connection issues (3f9ad09)
  • onboarding: handle host/cert errors on boot (b41caa9), closes #1215
  • onboarding: properly identify macaroon errors (3596f18)
  • payment: timeout payment requests after 60 seconds (368c814)
  • security: disable electron node integration (ae2103a), closes #29
  • startup-fetch-activity: fetch activity history when grpc is ready (b655252), closes #1193
  • style: ensure modal covers full page (7ce3333)
  • ui: add autofocus to search input field (a4ab318)
  • ui: add pointer cursor to submenu headers (40a66ac)
  • ui: don't show angle icon for logout link (586ef4f), closes #1242
  • ui: ensure error messages are visible (af86dd0), closes #1206
  • ui: ensure main content area is scrollable (8586c7e)
  • ui: ensure menu can overflow main content (37b5a3e), closes #1328
  • ui: ensure settings menu closes properly (16e4260), closes #1242
  • ui: homepage layout glitch (e24c4c8), closes #1245
  • ui: implement invoice status update in request modal (b310305)
  • ui: improve english grammar on sync page (1707e28), closes #1204
  • ui: increase qrcode size for easier scanning (a0f043f), closes #1263
  • ui: left-align column text (cf95c8f)
  • ui: loading screen flicker on wallet start (3c74c03)
  • ui: make modal scrollable (ecde62b)
  • ui: reword blockchain syncing message (26a8921)
  • ui: set global error z-index to 99999 (f109880)
  • ui: vertically centre settings menu icons (4c8d7bd), closes #1242
  • wallet: add fiat amount to request summary (58bba03)
  • wallet: handle invoices with msat amounts (d47bad6), closes #1273
  • wallet: phots to ltc conversion (71320c9), closes #1345
  • wallet: satoshi to millisatoshi conversion (f838df2), closes #1332
  • wallet: show as unconfirmed transactions (6959f26), closes #1344
  • wallet: support uppercase payment requests (f6c6b23), closes #1266
  • wallet: update invoice modal style (487d0d5), closes #1143
  • wallet: update payment modal style (eb8bcc1), closes #1144
  • wallet: update transaction modal style (0532d88), closes #1142 #1141

Performance Improvements

  • activity: use purecomponent for activity list item and extract it (ccc4e03)
  • app: remove irrelevant to render state vars (9c8ba2d)
  • boot: load files asynchronously (6d22a53)
2019-01-16
ledger-live-common v4.9.0 2019-01-15
ledger-live-common v4.8.1 2019-01-11
ledger-live-common v4.9.1 2019-01-17
lightning-peach-wallet v0.4.0-mainnet-beta

LightningPeach wallet v0.4.0-mainnet-beta

Release notes:

  • This release is public beta one on mainnet. It means that from now on you can send and receive payments on mainnet, as well as purchasing real goods through Lightning.
  • For security reasons we have limited time of active session. Now session is active only for 15 minutes, then you need to reenter your password. Please note, that stream payments in this case are not stopped or paused.
  • We have added the Merachants tab, on which you can see stores, that accept mainnet lightning payments. Refill your wallet with bitcoin and try the real world of lightning fast payments.

Verifying the Release

In order to verify the release, you'll need to have gpg or gpg2 installed on your system. Once you've obtained a copy (and hopefully verified that as well), you'll first need to import LighntingPeach Wallet's key if you haven't done so already:

curl "https://keyserver.ubuntu.com/pks/lookup?op=get&search=0x3B50C645039078ED" | gpg --import

Once you have LighntingPeach Wallet's PGP key you can verify the release (assuming manifest-v.4.0-mainnet-beta.txt and manifest-v.4.0-mainnet-beta.txt.sig are in the current directory) with:

gpg --verify manifest-v.4.0-mainnet-beta.txt.sig

That will verify the signature on the main manifest page which ensures integrity and authenticity of the binaries and executables you've downloaded locally. Next, depending on your operating system you should then re-calculate the sha256 sum of the binary or executable, and compare that with the following hashes (which are included in the manifest file):

cddd2019f89319b1f36caa6cc4e4922d940d52f79ef9e425d081c0fd843c5bb2  lightning-peach-wallet-0.4.0-mainnet-beta-mac.zip
79d1766a39a3a3662b81bd57abcd7bd3cf2b0b8811f627866cb95c8b3ff00133  lightning-peach-wallet_0.4.0-mainnet-beta_amd64.deb
da00a72b3a4c4b65827ee0a0e1636e1978e2dafb6dbf805473b126255a832803  lightning-peach-wallet-0.4.0-mainnet-beta.dmg
3a5d3ea921aa997f719f73f65c6273d4106671e9d9766bffe59ddb07fee3d767  lightning-peach-wallet-0.4.0-mainnet-beta.exe
ec8141e44527dca6edec49a65fe806a16cde0f46c0c442202383470222288491  lightning-peach-wallet-0.4.0-mainnet-beta-x86_64.AppImage
31f6793df947bb45e6b48a18ff05f81bbdfa8a123cb91cb36b732e86bf70f8c5  lightning-peach-wallet-setup-0.4.0-mainnet-beta.exe

One can use the shasum -a 256 <file name="" here=""> tool in order to re-compute the sha256 hash of the target binary or executable for your operating system. The produced hash should be compared with the hashes listed above and they should match exactly.

2019-01-11
lightning-peach-wallet v0.4.1-mainnet-beta

LightningPeach wallet v0.4.1-mainnet-beta

Release notes:

  • Bug with merchant logo display has been fixed.

Verifying the Release

In order to verify the release, you'll need to have gpg or gpg2 installed on your system. Once you've obtained a copy (and hopefully verified that as well), you'll first need to import LighntingPeach Wallet's key if you haven't done so already:

curl &#34;https://keyserver.ubuntu.com/pks/lookup?op=get&amp;search=0x3B50C645039078ED&#34; | gpg --import

Once you have LighntingPeach Wallet's PGP key you can verify the release (assuming manifest-v.0.4.1-mainnet-beta.txt and manifest-v.0.4.1-mainnet-beta.txt.sig are in the current directory) with:

gpg --verify manifest-v.0.4.1-mainnet-beta.txt.sig

That will verify the signature on the main manifest page which ensures integrity and authenticity of the binaries and executables you've downloaded locally. Next, depending on your operating system you should then re-calculate the sha256 sum of the binary or executable, and compare that with the following hashes (which are included in the manifest file):

709635b7187a68be33524314e6728bdc6943f5e4165e94d56839f7cee17d3824  lightning-peach-wallet_0.4.1-mainnet-beta_amd64.deb
e52d76e0c4c0ca3e9a6905f781bee00429ff2171a172383e131dbf93d87274b5  lightning-peach-wallet-0.4.1-mainnet-beta.dmg
3da4912a6c7a08c013d5aa7a082e8f4198ace3eb335c6a9588cfa24e314ecd11  lightning-peach-wallet-0.4.1-mainnet-beta.exe
4baae3703db0eaa5a9f1887676e88a4f881fdedea1530d009eb9119162f9e605  lightning-peach-wallet-0.4.1-mainnet-beta-mac.zip
79e3b154c51800a1454abe27c8d280e2b9198754e5fc765a9b2bbef29e7e67ce  lightning-peach-wallet-setup-0.4.1-mainnet-beta.exe
a9359f671bd8be3fceda41e7e4678e6351915bc323f2b7c95c03b0d6bcb89853  lightning-peach-wallet-0.4.1-mainnet-beta-x86_64.AppImage

One can use the shasum -a 256 <file name="" here=""> tool in order to re-compute the sha256 hash of the target binary or executable for your operating system. The produced hash should be compared with the hashes listed above and they should match exactly.

2019-01-17
BTC Pay Server v1.0.3.44 2019-01-16
BTC Pay Server v1.0.3.43 2019-01-15
WalletWasabi v1.1.0

Summary

This is our first major release since the 1.0. We have countless improvements in this release, most notably we changed Chaumian RSA Blinding to Schnorr Signature Blinding and we have introduced multiple denominations to mix on the change outputs. These denominations are always multiplications of the base denomination, which is currently 0.1BTC. Thus they will be 0.2, 0.4, 0.8, …

With this we will achieve significantly better anonymity gain per block space usage and faster anonymization of large amounts. However the changes here come with a caveat. Everyone has to update the same time. We call this a Wasabi hard fork and we plan to only do it when it is absolutely necessary. When this happens we change our backend query paths. When your client notices it, it notifies you by coloring the status bar red with the following message:

image

Newbie Guide

While setting up Wasabi is straightforward, even the Linux wizard with the longest beard can get stuck on the most basic tasks. In that case, take a look at the Installation Instructions guide.

Pro Guide

If you want to build Wasabi from source code or update the source code check out these instructions.

FAQ

  • Where is Wasabi's working directory located? Configuration, wallet and similar files can be found in %appdata%\WalletWasabi folder on Windows and in ~/.walletwasabi folder on Linux/OSX.
  • Can I use my own Tor instance, instead of Wasabi's built in one? If you already have Tor, and it is running, then Wasabi will try to use that first, if it is not running, then Wasabi will use its built-in Tor. If you are running a Tor daemon not on the default port, then you can configure it in Wasabi's Tools/Setting menu. If Wasabi is using your Tor daemon, then bear in mind that some Linux distributions' package repositories ship with out of date Tor. In that case, either remove or shut down that Tor of yours or make sure it's not out of date: Check Tor version: tor --version. If it's not at least 0.3.2.2, then see this writeup on how to update it.
  • Why are the binary sizes so big? Wasabi is using client side filtering and these filters must be synced before using the wallet. The size of these filters are currently about 90MB. These filters are included with the binaries to avoid initial wallet syncing.
  • Requirements? x64, linux, >win7, >osx.10.12.

Release Notes

This section is usually a summary of commits, pull requests and issues of this repository in a changelog format. However this time architectural changes were made to Wasabi, which requires a more consistent and understandable explanation, which you can read here. If you still require a changelog, please refer to the history of this GitHub repository.

2019-01-12

RFC

type rfc # title date status
bolt onchain BOLT 5: fix the requirements of `Revoked Transaction Close Handling`. 2019-01-15 Merged
bolt X fix a requirement mistake of `next_remote_revocation_number`. 2019-01-15 Merged
bolt peer protocol BOLT 2: `payment hash` not `revocation hash`. 2019-01-15 Merged
bolt transactions BOLT 3 : Fix ambiguity on HTLC transactions spendable by a penalty one 2019-01-15 Merged
bolt routing gossip BOLT 7: Add note for 'htlc_minimum_msat' being static 2019-01-15 Update
bolt X request a sendmany 2019-01-12 New Issue
bolt X Why are "d" and "h" mandatory? 2019-01-11 Closed
slip X Peercoin hrp. 2019-01-16 Merged
slip slip-0044 [slip-0044] add url for binance chain 2019-01-16 Merged
slip slip-0044 [slip-0044] add MNPCoin 2019-01-16 Merged
slip X add vee coin type 2019-01-16 Merged
slip X Add 916 META (Metadium Coin) 2019-01-15 Merged
slip X add bos 2019-01-15 Merged
slip X Add Adshares Network (ADS) 2019-01-11 Merged